Hi, it’s a quick Stable update we’ve prepared for you for the end of this week. Have a nice weekend and see you on Monday!

Highlights

  • We fixed some UI issues on Linux: O-menu elements are more visible again and the menu is positioned correctly. Plus, the context menu does not have a black border anymore
  • We fixed a crash on the extensions sidebar when right-clicking
  • We added more space on the tab bar to make it easier to drag an Opera window (macOS)
  • We fixed the 1px issue when watching full screen videos

All the details are listed in the changelog, as usual.

Installation links

Back to top
  • Vux777

    Hi Kornelia
    DNA-61326 didn’t make it into this build?

    edit DNA-61367

    • Kornelia

      Did not make it, sorry. It was verified yesterday so will be backported to the next build.

    • Mike

      what bug is it?

      • Vux777

        on OS X, extensions sidebar is bugged
        input elements can’t get focus, so basically user can’t type anything in it

    • We fixed some UI issues on Linux: O-menu elements are more visible again and the menu is positioned correctly. Plus, the context menu does not have a black border anymore

      • Vux777

        who’s “we” ?

  • ArkuS

    PL:
    Witam. Pasek na dole podczas oglądania filmu w trybie pełnoekranowym został naprawiony. Jednak jest jeszcze ten sam pasek podczas przeglądania normalnych stron www.

    ENG:
    Hello. Bar at the bottom while watching a movie in full screen mode has been fixed. However, there is still the same bar when browsing normal web pages.

  • andy-drew

    Hello,
    I’m posting from Ubuntu 17.04. I don’t see the red O-menu (as said in the changelog for this version). Is it normal since Unity has its global menu or am I missing something? Thanks.

  • iPristy

    I’m not a big fan of wallpaper in browser they are just distraction but now you are forcing user to use one, if just using white everything goes gray now. I have made total black wallpaper, but it’s not getting any better. Maybe i will made seamless black texture wallpaper, not quite sure how to fix this.

    • Night Man

      they are not forcing anything
      if you want to use wallpaper . just use it
      if you dont want , dont use it ..

      • iPristy

        Before this version everything looked better without wallpaper but now it’s worse. I liked white look but now is gray with white text for speed dials before was black text.

  • Speeddial broken as tiny white text is hard to read on the default grey

    macOS 10.12.5

  • AM_PM

    Can anyone tell me WHY is the Notes extension ( none of them ) are working .
    It does CUT/COPY using right-click but NOT responsive AT ALL on keyboard commands. Opera Stable and Developer ( latest ). MBP 10.12.5. REAALY need this to work, as we’ve got 8 people her that rely on it in other to cut/paste pre-written emails etc. PLEASE GUYS. We are Opera user since Opera 9 I believe. BUT YOU CANNOT AS THE COMPANY YOU BECAME RELEASE A STABKE VERSION WITH SUCH A SIMPLE, VERY MUCH USED FEATURE BROKEN. Thank you. PS: Using the V7 Notes Extension by Vux777

  • Mr. Legit

    thanks guys, for fix the problem with the Omenu on Linux

    i see this problem with opera 45, i cannot disable/ active the “extensions hidden”

    (opera://extensions) > /usr/bin/opera –show-component-extension-options

    http://imgur.com/a/jK8xj (I disabled them in version 44, but now I can not turn them on or off)

    has solution?

    • ArkuS

      Also, I would like to know how to fix this and if you know maybe any other commands that let you discover hidden settings etc?

      • Mr. Legit

        me too, i need fix this problem with the ‘extensions hidden’

        not sorry, is the only command i know

  • Still can’t play videos. Not sure what types, but html5 and flash plays. Check out the microsoft’s fluent design site http://fluent.microsoft.com – can’t play the video.

    Also can’t play twitter videos.

    I tried Opera 45, Opera Beta 46.0.2597.6-1 and 46.0.2602.0-1. I’m on ArchLinux.

    • Mr. Legit

      try update the package “chromium-codecs-ffmpeg-extra”

      • Nope. First, there’s no such named package. Second, when try to install `opera-beta-ffmpeg-codecs` respectively for my `opera-beta` package it fails to build: `ERROR: Failed to extract chromium-59.0.3071.29.tar.xz`

        What is strange to me also is that i just can’t install chromium-dev, chromium package neither.

        • Mr. Legit

          It’s very strange what you say…

          I use xubuntu, i try install the “chromium-codecs-ffmpeg-extra” on Opera, Chrome / Chromium and it really works for me…

          https://packages.ubuntu.com/trusty/chromium-codecs-ffmpeg-extra

          This is the package i said before my comment

          • I don’t know where you see that I’m saying that I’m using Ubuntu et al.
            As I said, in my first comment – i’m on ArchLinux, it’s not from debian family.

          • Mr. Legit

            i’m sorry, i hope u fix the problem with ffmpeg-codecs

            i never use arch linux.

          • John Rambo

            Try installing opera-ffmpeg-codecs, rather than opera-beta-ffmpeg-codecs.

          • Ari

            You can download the opera-beta-ffmpeg-codecs package from the Herecura’s repo (https://repo.herecura.eu/herecura/x86_64/ ), and navigate to Opera’s root folder, create a new subfolder lib_extra, and extract libffmpeg.so from the package to this subfolder. No need to install anything.

  • redfox

    When I click an URL in a desktop application (Thunderbird etc.), Opera opens, but the window focus remains on the previous application window. As a result, the Opera’s window stays covered by the other app window.
    The bug does not occur when Opera is already open before the action (click).
    It also does not occur when the flag #reborn-win7-aero-skin is set to disabled.
    Win7/32

    As for the Czech localization: It should be “Nastavit tmavý motiv”, instead of “Povolit temný téma” in the Settings/Browser/User.. . Please, correct it.

  • Mike

    Active title bar still the same colour as the inactive one…. 🙁

    • Jones

      Also doesn’t follow title bar color on w10 if enabled.

    • redfox

      There is a difference, but barely noticeable.

  • Jones

    Google looks really old after applying this update.
    View screenshot: https://ibb.co/mo1h8F

    • Timo Maas

      I have the same problem

      • Jones

        Doesnt seem to happen while VPN is on.
        See image: https://ibb.co/fN6h8F

        • Timo Maas

          you are right, very strange!

        • Timo Maas

          Actually I noticed, that if i use the canadian VPN and I logon to google.ca it’s still the old one. USA VPN is ok

          • Jones

            Same result.

    • redfox

      Seems like a mobile version of Google.

  • Timo Maas

    I have the old google home page with this new version

  • Pavel A.

    I also have the old google problem. It appeared randomly today BEFORE the update, still here after it.

    • Jones

      Turn on the built in vpn and try reloading the page.

      • Pavel A.

        Works, but just a bandaid solution. Thanks

        • Robert Tomaszewski

          Hello Pavel,
          Could you check if the problem has gone if you switch off VPN now?
          If the problem is still reproducible could you share what is the location (country) where you use Opera Browser? Ofc if you do mind 🙂
          Thank you in advance!

          • Pavel A.

            It appears to be working normally now, without the VPN. What changed?

          • Robert Tomaszewski

            Thank you Pavel!
            This means that it was most likely on Google side 🙂

  • Becky J.

    Old Google also randomly appeared for me just now, right before O45 updated itself, I’m guessing from .812 to .881 (it’s .881 now anyway). Still have old Google after the update/restart. Yes, turning on the VPN fixes it, but I had turned the VPN off a couple of weeks ago because I was having some issues with it, so unless those VPN issues are fixed, this is not going to go well.

    But my other big complaint is WHY do the Opera devs think we need the giant menu tab?!! Really, at this point everybody has been online long enough to be able to find a browser’s menu with just the little O logo (for Opera), or the three dots (for Chrome), or the three lines (for FF). No one needs a huge tab that screams “Menu”.

    • Leonardo Gomes

      It seems to be Google doing browser sniffing as usual. For noew you can use an extension to change Opera’s user agent to fix the problem.

      • Becky J.

        FWIW, I have VPN on and now even with that I’m getting old version Google, so apparently even that gerry-rigged solution isn’t reliable. I’ll look into using an extension. But again, my point with the giant menu label…they assume users are fine with using extensions to fix this oddball problem, but can’t find the menu???

        • Leonardo Gomes

          They who? I and some other users are pointing out the use of an extension as a workaround until the problem is fixed and that’s just it.

          • Becky J.

            Probably moot since right now it appears to be fixed, but the “they” referred to the developers. Just seemed odd to me that they felt users weren’t sophisticated enough to locate the menu without a big label (or even worse, a distracting black bar down the side of the window), but they were okay with releasing an update that required users to perform what is IMO the more advanced task of adding an extension in order to properly use the most popular search engine in the world.

          • Leonardo Gomes

            You are assuming that the issue was caused by latest Opera stable update but there are very high chances that Google caused it.

            I didn’t see that issue happening here as well as many others, not to mention that it also affected users with other version of Opera.

    • Leonardo Gomes

      When there wasn’t a ‘menu’ label together with Opera’s icon, many people didn’t know that clicking on the icon opened the menu, so it’s probably the reason for them to have added the ‘menu’ label.

      • Becky J.

        Well, I wish they would have at least an option to get rid of the huge, annoying label for the 99% of users who are bright enough to be able to find the menu on a browser. >:(

        • Leonardo Gomes

          I would say it’s exactly the opposite: 1% (OK, maybe 10%) are savvy enough to realize that there is a menu there.

          BTW, if you pin the sidebar the ‘menu’ label goes away.

          • Becky J.

            I switched from FF to Opera, I dunno, maybe a year-ish ago, having never seen Opera desktop before (I do have it on my phone but rarely use it), and I found the menu in the first thirty seconds. But anyway, pinning the sidebar might be okay if it was transparent or even translucent, but not opaque black; I’d rather deal with the menu label. Or hey, maybe I can find an extension to get rid of the label or change the sidebar color/opacity. 😉

          • Leonardo Gomes

            Well, just because you don’t have difficult on finding the menu in a program doesn’t mean that you can assume that others will not have.

  • Vorlath –

    What’s up with the HUUUUUUUUUUUGE menu bar and icons? Holy crap!

    Also, google is all text. Is this going to be fixed?

  • Will Opera ever provide Theatre Mode for YouTube?

    Opera just centers and adds black sides, not changing video size like Chrome.

    • Leonardo Gomes

      I can’t see the difference here. I’ve tried a few videos here and they looked the same using theater mode both in Opera and Chrome.

      • I’ve never seen video frame change size in Theater Mode (as far back as I can remember, we’re talking years).

        I’m on latest Stable version, Win10-64, 100% Zoom. Norwegian language.
        No related extensions active.

        Any tips for troubleshooting this?

        • Leonardo Gomes

          I don’t see any change on video size here, nor in Opera nor in Chrome.

          • I have very different behavior in Chrome. Theater Mode enabled increases video frame size considerably and changes top frame to black.

            Chrome Version 58.0.3029.110 (64-bit)

          • Leonardo Gomes

            Do you have screen shots?

          • Bingo, I figured it out.

            It has nothing to do with browser, it depends on account settings you are logged into YouTube with.

            In Chrome, I’m logged into account that has the new YouTube design enabled.

            The new design works equally well in Opera and can be tested here:

            https://www.youtube.com/new

            Difference in Theatre Mode, shown with 100% zoom scaled at 1920×1080.

            Opera
            https://dl.dropboxusercontent.com/s/x9tarzi89uxwku6/Opera_02.jpg

            Chrome
            https://dl.dropboxusercontent.com/s/5dsxvz97b16m4da/Chrome_04.jpg

          • ultraviolet

            glad you figured it out. i didn’t know about the ‘new’ youtube design and trying out it looks a lot nicer

          • Ari

            Thanks man for the tip on the new design. I hated when theatre mode actually did nothing at all besides centring the video.

  • I’m would be really appreciate if I can manage video navigation in pop out video. Rewind 10 seconds left arrow, forward 10 seconds right arrow.

  • Erik

    I can confirm big black borders around menu are gone. Thank you!

    • Ari

      Lol you’re right haven’t realised about it gone

  • Jozka Jozin

    When switch from Opera app to another app and back to Opera, so then isn’t focus in address bar when open the new tab.

    MacOS version 43 – 45v still present

  • Can Tezcan

    still no *show system color on top bar* fix and white menus at night mode? :/

    • Leonardo Gomes

      ‘show system color on top bar’ was removed on latest developer build.

      • Can Tezcan

        omg is that mean we wont be able to use our deskop color on top bar anymore? 🙁

      • lucrudites

        I hope they add Fluent Design System on Opera, if they add this feature, opera will get a excelent UI

  • redfox

    The active Tab should be more lighter than the others, the color difference is hardly noticeable in the dark theme.

  • Opera does not release RAM when a tab is closed, sometimes it uses more RAM (even if the next tab is is already active and loaded)

    macOS 10.12.5

  • Piotr

    YouTube on Opera. When you remove grey bar on the left side of window?

    • Leonardo Gomes

      What gray bar?

  • K. K. VinayKumar

    Opera in Windows 7 64bit is not smooth. Everything is choppy including animations and scrolling of PDF files also become choppy.

    • Roman

      +1
      Problem appeared with Opera 45

  • Kamil

  • m80n27

    Could you check what’s going on and why: groupon.co.uk? I have the problem from many previously versions of Opera, but I’ve decided to write about it now. Thank you for any help

    • Ari

      And the problem is? It’s loading fine for me

      • m80n27

        Cpu usage, Opera frozen. I use uBlock Origin and it shows about 400 blocks on that page. Without adblock page and Opera looks fine. So maybe that was the problem

        • Ari

          Hmm weird, I’ve got the same extension. The only problem was the first time that it blocked a pop-in ad or something so didn’t allow me to navigate correctly so disabled ublock, reloaded, the ad appeared, I closed it, re-enabled ublock and reloaded it and all fine.

          • m80n27

            After disabled ublock and re-enabled, page loads fast. I don’t now why, but problem solved

  • redfox

    Could you please configure Opera to not save “ssdfpxxxx” files into Opera profile folder on each exit? There are tons of them already there, not good for SSD.

    • nanana1

      Agreed….ssdfpxxxx files seem to proliferate itself in the profile folder after each Opera startup use.

    • Leonardo Gomes

      Here I only have one of those files, what seems to be updated on every time Opera is closed.

      • redfox

        I have found in an old Opera forum thread, that these files are always created (at every Opera exit) if the autoupdater has been disabled (either in firewall, or by deleting/renaming the opera_autoupdate.exe). If you keep it enabled, you can have only one such file in the profile folder. I have plenty of them…
        As far as I know, Chrome does not create them, so why Opera?

  • guest

    new version has bad ui 🙁 Looks like Opera made for MacOS users, not for Windows users…

  • redfox

    Bug in the Horizontal drag link’s text selection:

    If you select part of the hyperlink’s text and release the left mouse button, Opera goes to the URL of the link, like it was normally clicked. It occurs only on some web pages, like idnes.cz or nyx.cz (top menu).
    Sometimes, the link’s text selection does not work at all, at the same site.

  • FluffyBoyo

    How about extending the dark UI mode to also include ALL settings pages, add-on pages and experiments etc. A full real dark mode mode which works across all Opera areas. Optional on each settings, extensions p[age to turn dark mode on or off, once the master dark mode is ON.

  • Yoast

    Problem playing mp3 links for example on
    https://waarneming.nl/soort/sounds/150?rating=7

    Click any of the little play buttons to try. Opera used to just play the sound, changing the play button into a stop button.

    But now it loads some opera-generated page with embedded media player. This is very annoying as you now have to hop back and forth between two pages.
    Is it possible to get the old functionality back?

    • Leonardo Gomes

      It also happens on Chrome and Firefox, so it’s something on the site side.

      • Yoast

        I just found it is connected to the flash settings, not a change on the site itself.
        opera://settings/?search=flash
        I recently set this to “click to play”, but when I put it back to “allow sites to run flash” then it works again as it should.
        AFAIK playing mp3 is not flash, but anyway I added the site to the exceptions and problem solved for now.

  • Mind Augas

    Hi, I was using Opera browser for windows for several months and I liked it very much. But recently after the newest update, also one update before that, browser screen started to flash for short moments, like flickering. Also after pressing to start browser the desktop is blured with transperent screen till browser loads startpage. I have not any add ons in browser. Also I use integrated gpu, I do not have a graphic card. I hope you will be able to fix it, it is the best browser despite those strugles!

    • Kornelia

      Hi, could you try running Opera from Terminal using this parameter –disable-direct-composition? Please let me know if this helps.

      • Mind Augas

        Where is terminal?

      • Gordon Freeman

        Adblock icon is then unfortunately not clickable anymore.

      • Roman

        If opera.exe->compatibility->Disable desktop composition is enabled, the problem dissapears. But this is not a permanent solution. Problem appeared with Opera 45.

  • Andrey
  • AM_PM

    not wanting to be a pain, but for us each day is HARD without it.
    Can anyone tell me WHY is the Notes extension ( none of them ) are working .
    It does CUT/COPY using right-click but NOT responsive AT ALL on keyboard commands. Notes V7 MBP Sierra 10.12.5

  • LouisJ

    It would be nice to be able to prevent closing the browser by closing the last tab on MacOS. Thanks

  • xphst0s

    Hi,
    I think there is a bug.
    Opera Version: 45.0.2552.881
    OS: Windows 10 Build 15063

    The speed dial’s tiles font colour is turned to white while the background of my speed dial remained that light grey. (Dark theme enabled)
    It’s really hard to read.

    I tried to return my theme into the light one but nothing changed.
    The color is stored in the “–theme-text-color” variable.

    I also tried to find the speed_dial.css but I had no luck.
    (It would be really nice if we could have access into those css files for customization purposes or maybe a control panel into the settings for those they don’t know CSS stuff.)

  • Roger Smith

    There is a huge bug in this one and the previous build regarding streaming video content:

    https://www.reddit.com/r/operabrowser/comments/6d5p3p/full_screen_video_has_white_stuck_in_both_top/

    Anytime I put youtube or any other flash/html5 Full screen there is two white dots up top Both of the top cornersg and this only happened with the big redesign in Version information Version: 45.0.2552.812 (PGO) – Opera is up to date Update stream: Stable System: Windows 7 64-bit (WoW64)
    Please fix this horrible bug

    http://i.imgur.com/5VS1YPZ.jpg

    [–]Gynura 1 point 2 days ago
    The new version of Opera since this post was submitted (45.0.2552.881) still has the white corners. I also use Windows 64-bit. I noticed the white corners on Netflix in full screen. Very annoying, once you notice this it’s hard to not see it 😛

    Please, please get rid of these weird white dots in the top corners

  • K. K. VinayKumar

    Opera in Windows 7 64bit is not smooth. Everything is choppy including animations and scrolling of PDF files also become choppy.

  • Pavel A.
  • Steven D.

    Anyone else catching this bug on Windows 10 64-bit: Trying to access bookmarks via the ‘heart’ icon on speed dial, when clicked, bookmarks won’t open. I have to close the speed dial tab and open new speed dial tab, then I can click the heart icon and bookmarks will open. I can’t seem to replicate on my Windows 7 machine. It’s not all the time either on the 10 machine, but it’s fairly frequent. It’s occurred in each Opera 45 stable build at this point.

  • Chawoobie

    I have latest version of Opera Stable installed on three computers. On two it is working fine. On one laptop, clicking on the Block ads icon or the download icon don’t do anything. I found that if I uncheck the “Use hardware acceleration when available” box in the settings, they work fine. Interestingly, on my desktop, the two icons (block ads and downloads) work fine even with hardware acceleration enabled.

    • Me too. Only the add bookmark icon works with hardware acceleration on my Windows 10 64 bit machine and Intel Graphics HD 520 with latest HP support drivers.

  • L33t4opera

    New build – Opera stable 45.0.2552.888 😉

    • Kornelia

      Hey, wait for me! 😛

  • This build the page http://www.collegehumor.com/post/7045250/10-hilarious-pics-we-can-all-agree-with would cuase massive RAM usage (2.4GB) & a 90% CPU usage after sitting a bit

    Not tested with newer stable build but have seen it on and off in the previous ones

    macOS 10.12.5

  • Yeldekina

    Still have the bing ugly black mark when the sidebar opened.

  • Terry & Donna Mixon

    I loved Opera until they made it look like Chrome. And now it is as tempermental as Firefox. WTH guys… plus… your “update” won’t load. It just takes up CPU % and sits there like a big ole turd.