Hi,

Today, we’re updating the beta stream with some fixes:

  • DNA-61392 [Win] Misplaced submenus in O-Menu and bookmark bar folders
  • DNA-63771 [Linux] Black border on sidebar communicator strikes back on Intel graphic GPU

We also added some improvements for the Snapshot tool, specifically with more emojis 🙂

The full changelog is here.

Installation links:

Back to top
  • Eugene B.

    Thank you for these fixes!
    Please upload another developer build tomo, those SD bugs are so annoying. 🙁

    • Matheus Bombonato

      Yeah… I usually don’t have problems with bugs on the Developer branch, but this time is disrupting the whole usability 🙁

  • The button for editing the bookmark does not work on the Express panel.

  • xirit64

    I still can’t listen anything and “play” button does not work either when using a normal window http://www1.wdr.de/radio/player/radioplayer106~_layout-popupVersion.html and
    http://www1.wdr.de/mediathek/audio/wdr2/wdr2-klartext/audio-jupp-heynckes—kein-coup-fuer-die-bayern-100.html . Both play fine when used in a private window. 6 extensions are allowed access to private as well. How is this possible, lol?
    W7x64

    • Andrey

      Try remove wdr.de cookies

      • xirit64

        I’ve deleted everything (Ctrl+Shift+Del) many times, added extra cookies exceptions, allowed third-party everything, even deleted cookies and cookies.journal from the user directory, disabled extensions, nothing has worked. :/ Except when playing in private mode lol. Something must be stored in another place which is somehow not accessible.

    • xirit64

      If I remove the file “Preferences” from the user Roaming directory and load up the browser it plays. What can it be?

      • Andrey

        flags, hardware acceleration, opera adblock

      • Leonardo Gomes

        Settings, broken profile.

        • xirit64

          And the next question is how did that happen and how can it be fixed, some entries that block the site from working in a normal window should be removed, but which ones?

          • Leonardo Gomes

            Extensions would be my first choice.

          • xirit64

            Did some file transfering to and from a new profile, installed extensions again and was working fine until I changed the language from english to german/changed one icon in an extension… broken again 🙂 unbelievable.

    • xirit64

      Well… copied Preferences from a clean profile, installed no extension at all and disabled images in the settings as I’m very low on bandwidth. Both links work fine in the beginning. After using the browser for some hours (with closing and opening the browser numerous times) the problem of no playing re-appears.
      Somehow the page can’t get access to wdr-wdr3-live.sslcast.addradio.de

    • xirit64

      Seems that disabling the images in the settings and working with the browser for some time in this way causes the corruption.

  • Can this be released the 49s this month?

  • Chawoobie

    While the Browser Identification in About Opera is listed as – Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/62.0.3202.38 Safari/537.36 OPR/49.0.2725.18 (Edition beta), my bank website keeps identifying it as chrome 27 or an outdated version of Mozilla. As a result, I have to click their box to keep using Opera.

    Any idea as to why the Browser ID is identified incorrectly? Is this an Opera or bank issue?

    • Lookso

      Your bank is detecting browser badly. You can use “User-Agent Switcher” extension: https://addons.opera.com/extensions/details/user-agent-switcher/ if you would like to, but you also need to change rules in this extension “Options” page, because the build one are outdated.

      • Chawoobie

        Thanks. I have been trying several switchers but, as you say, the rules are outdated.

      • Chawoobie

        Thanks again. I added the user-agent add-on you suggested. Unlike to others I have tried, editing the options was easier and straightforward. I copied and pasted in the current Browser ID info from Opera, and selected that as my default. So far, all is well!

  • John Johnston

    today i got rid of opera stable and i downloaded opera beta i cant stop taking selfies its awesome and you can add emojis to your messages too i love it

  • FluffyBoyo

    How about trying out your own Opera flavour of Kinetic mouse wheel scrolling back and forth for the tab bar, similar to FF’s kinetic scrolling. Will be very handy for those using 100-300+ open tabs. So when using 200 odd tabs you can clearly see the full fav icon and the ones either side as you scroll left and right. And have settings for the kinetic scrolling control, speed, acceleration and fall off etc.

    And lets not forget the dark mode UI for all, settings etc pages. Very important for a fully complete dark mode UI.

  • Penkov

    Do you have any known issue with facebook messenger in sidebar?
    I don’t see the sign in area of the page.
    And whatsup in sidebar reads “Something went wrong…”
    Tried turning off and on VPN and ad blocking feature. Also cleared browsing data from the beginning of time for cookies and other site data, cached images and files, autofill form data, third party services data.
    Ideas?

    • John Johnston

      are you by any chance using the web panel addon as it does conflict with the messenger sidebar

      • Penkov

        I don’t use web panel addon.
        For debugging purpose, do you think I should completely remove extensions one by one or I could only disable them one by one and try?

        • John Johnston

          do it one by one as one of your extns is causing the problem

      • Penkov

        OK, problem solved!
        I disabled all the extensions I don’t use, restarted the browser and voila – everything’s good in the hood tonight. Thanks for the tip!

  • L33t4opera

    New build – Opera beta 49.0.2725.23 😉